Back to page

− Links

 Print 

Perlのアップデートで悩む :: Nest Of Hawk

xpwiki:Perlのアップデートで悩む

Gentoo Linuxな生活​/システム管理関連[1]

シェル言語のアップデート anchor.png[2]

シェル言語には、いろいろあります。古くはsed,awkに始まり、perl,ruby,python,PHP等、最近ではかなりの量のシェル言語がありますね。 で、つい先日perlがアップデートされました。このperl,シェルスクリプトを理解するご本尊だけは、

# emerge -u perl
# emerge -u libperl

でアップデートされるのですが、追加インストールされているモジュールが新しいperlで使えません。これでは意味がなぁぁい!

Page Top

どーいう弊害がでるか anchor.png[3]

ツールによっては、perlの追加モジュール(CPANといいますな)に入っているモジュールの処理に頼った作りをしている奴があります。こいつらが動作しなくなります。なので移し変えてやらないといけんのですが、いちいち

# emerge XML-Parser

等と一つ一つやっていてはらちがあきません。でもさすが!Gentooはちゃんと考えてある!

# /usr/portage/dev-lang/perl/files/perl-cleaner

と打てば、全て新規バージョン用に移行してくれるようでらくちぃ~ん!

でも、コレに気づくまでに何度も試行錯誤をしてたのよねぇ。くぅ~


Last-modified: 2009-08-19 (Wed) 00:29:25 (JST) (4115d) by maruo